)]}'
{"designate/objects/rdata_a.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC1035"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027address\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 1"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoWA%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that RECORD_TYPE \u003d 1 is defined in the RFC and not in the designate code anywhere, otherwise, I think it\u0027s confusing.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_aaaa.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC3596"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027address\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 28"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoV0%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_cname.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC1035"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027cname\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 5"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoVg%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_mx.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    # priority is maintained separately for MX records and not in \u0027data\u0027"},{"line_number":24,"context_line":"    RDATA_FIELDS \u003d [\u0027exchange\u0027]"},{"line_number":25,"context_line":"    RECORD_TYPE \u003d 15"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoVI%3D","line":25,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_ns.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC1035"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027nsdname\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 2"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoU8%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_ptr.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC1035"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027ptrdname\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 12"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoU4%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_soa.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027mname\u0027, \u0027rname\u0027, \u0027serial\u0027, \u0027refresh\u0027, \u0027retry\u0027, \u0027expire\u0027,"},{"line_number":24,"context_line":"                    \u0027minimum\u0027]"},{"line_number":25,"context_line":"    RECORD_TYPE \u003d 6"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoUw%3D","line":25,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_spf.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC4408"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027txt-data\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 99"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoUs%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_srv.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    # priority is maintained separately for SRV records and not in \u0027data\u0027"},{"line_number":24,"context_line":"    RDATA_FIELDS \u003d [\u0027weight\u0027, \u0027port\u0027, \u0027target\u0027]"},{"line_number":25,"context_line":"    RECORD_TYPE \u003d 33"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoUo%3D","line":25,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_sshfp.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC4255"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027algorithm\u0027, \u0027fp_type\u0027, \u0027fingerprint\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 44"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoUk%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/rdata_txt.py":[{"author":{"_account_id":8130,"name":"Betsy Luzader","email":"betsy.luzader@rackspace.com","username":"bluzader"},"change_message_id":"3262d1c03ddeadff401aaf3eaf7c3ac58ec5b8a3","unresolved":false,"context_lines":[{"line_number":21,"context_line":"    Defined in: RFC1035"},{"line_number":22,"context_line":"    \"\"\""},{"line_number":23,"context_line":"    RDATA_FIELDS \u003d [\u0027txt-data\u0027]"},{"line_number":24,"context_line":"    RECORD_TYPE \u003d 16"}],"source_content_type":"text/x-python","patch_set":3,"id":"AAAAXH%2F%2FoUg%3D","line":24,"updated":"2014-04-18 17:34:31.000000000","message":"Please add comment that number is defined in RFC.","commit_id":"5cc4d226caf17d3020b5669a374baa27d8c72deb"}],"designate/objects/record.py":[{"author":{"_account_id":741,"name":"Kiall Mac Innes","email":"kiall@macinnes.ie","username":"kiall"},"change_message_id":"6b913544e495b09b79f4df22e597eab080a495eb","unresolved":false,"context_lines":[{"line_number":51,"context_line":"        if len(self.RRDATA_FIELDS) \u003d\u003d 1:"},{"line_number":52,"context_line":"            setattr(self, self.RRDATA_FIELDS[0], self.data)"},{"line_number":53,"context_line":"        else:"},{"line_number":54,"context_line":"            rdata_values \u003d self.data.split()"},{"line_number":55,"context_line":"            if len(self.RRDATA_FIELDS) !\u003d len(rdata_values):"},{"line_number":56,"context_line":"                raise TypeError(\"Incorrect number of values. Expected: %s.\""},{"line_number":57,"context_line":"                                \" Got %s\" % (self.RRDATA_FIELDS, rdata_values))"}],"source_content_type":"text/x-python","patch_set":4,"id":"AAAAXX%2F%2Fz80%3D","line":54,"updated":"2014-04-26 08:59:41.000000000","message":"We\u0027ll need to use per-type regex\u0027s here, as it\u0027s valid for many fields in DNS to have whitespace inside a field..","commit_id":"16145607ad662cbf4181956625ca0c7405b32d79"},{"author":{"_account_id":741,"name":"Kiall Mac Innes","email":"kiall@macinnes.ie","username":"kiall"},"change_message_id":"9b98535014dc15452fe0c15c7126f95f526fe9bf","unresolved":false,"context_lines":[{"line_number":51,"context_line":"        if len(self.RRDATA_FIELDS) \u003d\u003d 1:"},{"line_number":52,"context_line":"            setattr(self, self.RRDATA_FIELDS[0], self.data)"},{"line_number":53,"context_line":"        else:"},{"line_number":54,"context_line":"            rdata_values \u003d self.data.split()"},{"line_number":55,"context_line":"            if len(self.RRDATA_FIELDS) !\u003d len(rdata_values):"},{"line_number":56,"context_line":"                raise TypeError(\"Incorrect number of values. Expected: %s.\""},{"line_number":57,"context_line":"                                \" Got %s\" % (self.RRDATA_FIELDS, rdata_values))"}],"source_content_type":"text/x-python","patch_set":4,"id":"bad4c104_839b83c8","line":54,"in_reply_to":"AAAAXX%2F%2FtO0%3D","updated":"2014-04-29 21:15:00.000000000","message":"TXT and SPF records can also have spaces..\n\nDo you see a dependency on the schema/validations moving in here?","commit_id":"16145607ad662cbf4181956625ca0c7405b32d79"},{"author":{"_account_id":8094,"name":"Vinod Mangalpally","email":"mrvinod@outlook.com","username":"vinodmr"},"change_message_id":"b3d232ee827c832c0d96fc47e9295bbc321ff5bd","unresolved":false,"context_lines":[{"line_number":51,"context_line":"        if len(self.RRDATA_FIELDS) \u003d\u003d 1:"},{"line_number":52,"context_line":"            setattr(self, self.RRDATA_FIELDS[0], self.data)"},{"line_number":53,"context_line":"        else:"},{"line_number":54,"context_line":"            rdata_values \u003d self.data.split()"},{"line_number":55,"context_line":"            if len(self.RRDATA_FIELDS) !\u003d len(rdata_values):"},{"line_number":56,"context_line":"                raise TypeError(\"Incorrect number of values. Expected: %s.\""},{"line_number":57,"context_line":"                                \" Got %s\" % (self.RRDATA_FIELDS, rdata_values))"}],"source_content_type":"text/x-python","patch_set":4,"id":"AAAAXX%2F%2FtO0%3D","line":54,"in_reply_to":"AAAAXX%2F%2Fz80%3D","updated":"2014-04-28 15:01:14.000000000","message":"I wanted to address this after we have the schema validation.  Added a TODO below to revisit this issue at that time.  Currently for the records that we have, this does not seem to be a problem.  The only thing that I am not sure of is the SSHFP record - if the fingerprint can contain spaces.","commit_id":"16145607ad662cbf4181956625ca0c7405b32d79"}]}
