)]}'
{"sysinv/sysinv/sysinv/sysinv/conductor/manager.py":[{"author":{"_account_id":9926,"name":"John Kung","email":"john.kung@windriver.com","username":"jkung"},"change_message_id":"58688349fbd8c14ff017cda3786a4effc0f341ea","unresolved":false,"context_lines":[{"line_number":6980,"context_line":"                                            config_uuid,"},{"line_number":6981,"context_line":"                                            config_dict)"},{"line_number":6982,"context_line":""},{"line_number":6983,"context_line":"    def _config_admin_for_stx_openstack(self, context):"},{"line_number":6984,"context_line":"        # set admin ignore_lockout_failure_attempts option to true to exempt"},{"line_number":6985,"context_line":"        # admin user from auth fail lockout."},{"line_number":6986,"context_line":"        auth_url \u003d \"http://keystone.openstack.svc.cluster.local/v3\""}],"source_content_type":"text/x-python","patch_set":1,"id":"9f560f44_e65ee7e4","line":6983,"updated":"2020-07-28 13:45:36.000000000","message":"There is a openstack::keystone::endpoint::runtime() manifest, consider updating _update_config_for_stx_openstack() to update the parameters required for openstack::keystone::user::option\n\nThis will provide better tracking of the configuration change (in hieradata) and consistent with puppet config framework","commit_id":"6fcfb3b640a86b3d36f276e4d596c65ee11487ab"},{"author":{"_account_id":28415,"name":"Lin Shuicheng","email":"shuicheng.lin@intel.com","username":"slin14"},"change_message_id":"75f754aa2fb493169cb5379eb09168f0d5df6d54","unresolved":false,"context_lines":[{"line_number":6980,"context_line":"                                            config_uuid,"},{"line_number":6981,"context_line":"                                            config_dict)"},{"line_number":6982,"context_line":""},{"line_number":6983,"context_line":"    def _config_admin_for_stx_openstack(self, context):"},{"line_number":6984,"context_line":"        # set admin ignore_lockout_failure_attempts option to true to exempt"},{"line_number":6985,"context_line":"        # admin user from auth fail lockout."},{"line_number":6986,"context_line":"        auth_url \u003d \"http://keystone.openstack.svc.cluster.local/v3\""}],"source_content_type":"text/x-python","patch_set":1,"id":"9f560f44_d180b18e","line":6983,"in_reply_to":"9f560f44_e65ee7e4","updated":"2020-07-29 01:10:59.000000000","message":"It seems the \"openstack::keystone\" in the puppet manifest is for host keystone. Such as it get identity_auth_url from \"platform::client::params::identity_auth_url\", which points to host keystone url. While for my case here, I need point auth url to keystone in openstack app. What is your suggestion for it? Thanks.","commit_id":"6fcfb3b640a86b3d36f276e4d596c65ee11487ab"}]}
